Back to overview
Resolved
Plugin taken down by Roblox.
Jun 18, 2026 at 6:24am UTC
Affected services
rolink.cloud
Resolved
Jun 18, 2026 at 6:51am UTC
The issue We believe have been resolved, but we are continuing to monitor the situation.
Affected services
Updated
Jun 18, 2026 at 6:27am UTC
We believe we have found the problem and are starting to fix.
Affected services
Created
Jun 18, 2026 at 6:24am UTC
Recently the Ro-Link Installer Plugin got taken down by Roblox and is facing some down time. We are actively looking into this issue and trying to find a fix.
Affected services